Brighthammer Adept Equipment not working

    • Brighthammer Adept Equipment not working

      Hi Folks,

      Thought i'd share this bug since it's not on the ''Known Issues'' list.

      While playing around with a fateweave deck idea using equipped Brighthammer Adept I noticed that it wasn't giving Candlekin entering play after it fateweave and Momentum 1.
      At first I thought that maybe the fateweave ''Deploy'' gem was the culprit, so I tried to replicate it using a "In all zones" gem and got the same result.

      Mother Beatrice (PvE) (Mercenary)

      Gem used in re-construction:
      Minor Diamond of Protection (+2 Defense)

      Cards used in re-construction:
      Brighthammer Adept (PvP) (Equipped) (Brighthammer Barbute)
      Pyre Ceremony (PvE) (Equipped) (Pyretic Vestments)
      Acolyte of Flame (PvP)

      *Note* Whenever I refer to Mother Beatrice's passive i'm choosing to Illuminate/Ignite 1, summon a Candlekin.

      Example 1 (Turn 2):

      On turn one I played the Candlekin that Mother Beatrice's passive created, followed by Brighthammer Adept on turn 2.
      This resulted in the following board state.

      Example 2 (Turn 3):

      During the opponents second turn he used Time Ripple to bring Brighthammer Adept back to my hand.

      At the start of my third turn I drew a second Acolyte of Flame.
      Then I played Pyre Ceremony (Equipped) to gain 5 temporary resources which made every card in my hand playable.
      That made the board state look like this:

      Example 3 (Turn 3):

      I proceeded to play the Brighthammer Adept triggering Mother Beatrice's passive once more which resulted in déjà vu. :D
      Anyhow, that looks like this.

      Example 4 (Turn 3):

      Following that I played the Acolyte of Flame which triggers Mother Beatrice's passive giving me another Candlekin followed by Acolyte of Flame's
      Deploy - Illuminate/Ignite 1, summon a Candlekin. This should result in two Candlekin with Brighthammer Adept modifications and two without.
      That should result in two 1 - 1's Candlekin and two 1 - 3's Candlekin.

      Sadly is this not that case as all Candlekin are missing text.

      Example 5 (Proof of Equipment):

      *Note* that may or may not be of help, but I found the wording on the equipment to be a little confusing.
      It states: ''As a Candlekin enters play under your control, it gets all socketed powers of this. Then, it gets Momentum 1.''

      How does that work if I use the fateweave gem which was my initial intent. As it enters play suggests at least to me that the card has already entered play and the effects are tagged on slightly after it.
      It could explain why the deploy effect never triggers, but if that's the case it still doesn't explain why the "In all zones" gem also doesn't work.
      If that makes any sense.

      P.S.: The Momentum 1 also never got applied just in case I haven't worded it right.

      Anyhow I hope it's useful. :thumbsup:
      “Excuses are a promise of repetition.”